Weird force values in Electrostatics module in COMSOL

Please login with a confirmed email address before reporting spam

Hey all,

I am trying to simulate the force between a large grounded sphere and a small charge but the values I get do not match the analytical solution and the force in the z-axis, which should be bigger, is around the same magnitude as the force value in the x- and y-direction. Does anybody have an idea of why this is happening and do you have any changes you think could be made to the simulation? The simulation is attached if ever you want to take a look. I have tried changing the dimensions of the spheres and I have made the mesh extremely precise by defining a very small minimum element size and a decently small maximum element size but the results are still off and weird.

Link to GoogleDocs folder with the COMSOL files. You just need to download the files. https://drive.google.com/drive/folders/10DEzXitjbGe_QprwhnCE1_vwViXD0fSH?usp=sharing

Thanks, Nic


0 Replies Last Post 08/05/2020, 15:21 GMT-3
COMSOL Moderator

Hello Nicolas Leblanc

Your Discussion has gone 30 days without a reply. If you still need help with COMSOL and have an on-subscription license, please visit our Support Center for help.

If you do not hold an on-subscription license, you may find an answer in another Discussion or in the Knowledge Base.

Reply

Please read the discussion forum rules before posting.

Please log in to post a reply.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.