Problem with the computation in High mach number flows

Please login with a confirmed email address before reporting spam

Hello everyone, I try to compute one on my fluid computation on Comsol but unfortunately I have the same error each time. When I use the laminar flow physics I can find a solution but when I use the high mach number flow physics my problem appears. This is the pop up message (Sorry the message is in french because I'm french but basically it says that "during the computation there is a non-integer power of a negative number") :

Etape ségrégée 2 Essai de calcul d'une puissance non entière d'un nombre négatif. - Fonction: ^ Echec dans l'évaluation de la variable. - Variable: comp1.hmnf.mu - Défini par: ((((comp1.T/comp1.hmnf.Tmu_ref)^1.5)comp1.hmnf.mu_ref)(comp1.hmnf.Tmu_ref+comp1.hmnf.S_s))/(comp1.hmnf.S_s+comp1.T) Echec dans l'évaluation de la variable. - Variable: comp1.hmnf.time_step_inv - Défini par: max(sqrt(emetric(comp1.u,comp1.v)((2^gmg_level)^2)),comp1.hmnf.mu/(((0.25comp1.hmnf.l_mix_lim)^2)comp1.hmnf.rho)) Echec dans l'évaluation de l'expression. - Expression: nojac(comp1.hmnf.time_step_inv/comp1.hmnf.locCFL) Echec dans l'évaluation de l'expression. - Expression: d((-comp1.hmnf.rhonojac(comp1.hmnf.time_step_inv/comp1.hmnf.locCFL)(comp1.ep-nojac(comp1.ep))test(comp1.ep))*(dvol),{test@2}) - Caractéristique: Solveur stationnaire 1 (sol1/s1)

I have join a screenshot of my geometry, it's a basic one but I need it. Eventually, my initial value is the mach on x-axis : M=4. The temperature doesn't change during the fluid flow.

Thank you for your help.



1 Reply Last Post 17/10/2020, 11:54 GMT-4
COMSOL Moderator

Hello Jonathan Pressoir

Your Discussion has gone 30 days without a reply. If you still need help with COMSOL and have an on-subscription license, please visit our Support Center for help.

If you do not hold an on-subscription license, you may find an answer in another Discussion or in the Knowledge Base.


Please login with a confirmed email address before reporting spam

Posted: 2 months ago 17/10/2020, 11:54 GMT-4

Hi Try load ramping. Initially take all values at the least. Like Inlet pressure = 1[atm], T_inlet=200[K], Mach=0. Then find a solution. Add another study and then ramp up any of your parameter in that study. Take the last solution from that study and then ramp up another parameter. Continue like this.

This is how I fixed this up with my analysis. Same trouble I faced for a very long time. Maybe this works for you.

Hi Try load ramping. Initially take all values at the least. Like Inlet pressure = 1[atm], T_inlet=200[K], Mach=0. Then find a solution. Add another study and then ramp up any of your parameter in that study. Take the last solution from that study and then ramp up another parameter. Continue like this. This is how I fixed this up with my analysis. Same trouble I faced for a very long time. Maybe this works for you.

Reply

Please read the discussion forum rules before posting.

Please log in to post a reply.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.