Note: This discussion is about an older version of the COMSOL Multiphysics® software. The information provided may be out of date.

Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

COMSOL 4.3 with MATLAB error 2

I have the code that have for loop.
Before the first loop is finished, we met several error messages




??? Error using ==> mphinterp at 317
mphinterp (292): Java exception occurred:
Exception:
java.lang.RuntimeException: Error in reInitializeModel
(rethrown as com.comsol.util.exceptions.FlException)
Messages:
Error in reInitializeModel






??? Error using ==> mphinterp at 317
mphinterp (292): Java exception occurred:
Exception:
java.lang.NullPointerException
(rethrown as com.comsol.util.exceptions.FlException)
Messages:





??? Error using ==> mphinterp at 317
mphinterp (292): Java exception occurred:
Exception:
org.eclipse.emf.cdo.common.util.TransportException: java.util.concurrent.TimeoutException
(rethrown as com.comsol.util.exceptions.FlException)
Messages:
java.util.concurrent.TimeoutException



Is it a memory problem?
We have a 16GB RAM.
I increased the java memory to 7GB.
But, I have that problem continually.
May I get the solution?

Kyungnam Kang

3 Replies Last Post 14/02/2013, 22:29 GMT-05:00
Mattia Montanari
Posted: 5 years ago 14/02/2013, 06:45 GMT-05:00
Error using ==> mphinterp

here is where you shuold look for your error :-)
Error using ==> mphinterp here is where you shuold look for your error :-)

Posted: 5 years ago 14/02/2013, 22:29 GMT-05:00
When I simulate short loops about ~1600, I could get a results
However, if I increase the loops over the 1600, I could not get the results with above error message.

I think that it is not the problem about the code.
When I simulate short loops about ~1600, I could get a results However, if I increase the loops over the 1600, I could not get the results with above error message. I think that it is not the problem about the code.

Posted: 5 years ago 14/02/2013, 22:29 GMT-05:00
When I simulate short loops about ~1600, I could get a results
However, if I increase the loops over the 1600, I could not get the results with above error message.

I think that it is not the problem about the code.
When I simulate short loops about ~1600, I could get a results However, if I increase the loops over the 1600, I could not get the results with above error message. I think that it is not the problem about the code.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.