Requisitos de Sistema - COMSOL Multiphysics® 5.2a

Estes requisitos são comuns à todas as plataformas:

  • Uma placa de rede funcionando e conexão com a internet são recomendadas durante a instalação.
  • Pelo menos 1 GB de memória, mas são recomendados 4GB, ou mais, por processador.
  • 1-5 GB de espaço em disco, dependendo dos seus produtos licenciados e das opções de instalação.
  • Adobe® Acrobat® Reader 10.1.9, 11.0.06, ou mais recente, para visualizar e imprimir a documentação do COMSOL® no formato PDF.

Para mais recomendações acerca do hardware, acesse este texto da nossa base de conhecimento.

Licenças Flutuantes em Rede (FNL)

A licença do tipo flutuante em rede (FNL) é suportada por redes heterogêneas compostas por computadores Windows®, Linux®, e Mac OS X. Tanto o gerenciador de licenças como o software COMSOL® podem ser executados em Windows®, Linux®, ou Mac OS X e ambos podem ser executados em um único computador. Este tipo de licença é recomendado para melhor performance em high-performance computing (HPC) e é necessária para paralelismo de memória distribuída, incluindo modelagem híbrida.

Class Kit License (CKL)

Os requisitos de sistema para licenças do tipo Class Kit License são similares àqueles das licenças do tipo Floating Network License.

Application Builder

O Application Builder é suportado pelo sistema operacional Windows®.

Requisitos de Sistema Operacional

Além dos requisitos de sistema operacional listados abaixo, veja os Requisitos para a Linha de Produtos de Interface para conhecer os requisitos específicos do CAD Import Module, Design Module e da linha de produtos LiveLink™.

Windows® macOS Linux®
Sistemas Operacionais 64-Bit
  • Windows® 10
  • Windows® 8.1
  • Windows® 8
  • Windows® 7
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows Server® 2008 R2
  • Windows Server® 2008
  • Windows HPC Server 2008 R2
  • Windows HPC Server 2008
  • Windows Vista®
Mac OS X 10.7 e OS X 10.8, 10.9, 10.10, 10.11 e 10.12
  • Debian® 7 e 8
  • Red Hat® Enterprise Linux® 51, 6 e 7
  • Ubuntu® 12.04 LTS, 14.04 LTS e Ubuntu® 16.04 LTS
  • OpenSUSE® 13.2 e OpenSUSE® Leap 42.1

1 Somente suportado para operação em modo servidor, modo batch, ou cluster.

Requisitos Específicos dos Sistemas Operacionais

Linux®
  • Biblioteca GNU C versão 2.7 ou posterior1.
  • Linux® kernel 2.6.18 ou posterior.
  • Processador Intel® Pentium® IV, ou AMD Athlon® XP, ou posteriores.
  • Flexnet® requer Linux Standard Base (LSB).

1 Se você possui uma versão mais antiga do que 6.0.9 da libstdc++, poderá ser necessário iniciar o COMSOL com a opção -forcegcc.

Sistema de Ajuda

Os seguintes navegadores de internet não são suportados quando o modo de ajuda é configurado para navegador:

  • Google Chrome™
  • Microsoft Edge™

Sistema de Ajuda no Linux®

Para que o sistema de ajuda funcione no Linux®,, os seguintes pacotes precisam ser instalados:

  • Debian® e Ubuntu®: libwebkitgtk-1.0-0
  • RHEL: webkitgtk (não incluído no RHEL7, mas disponível em EPEL).
  • openSuSE: libwebkitgtk-1.0-0 ou libwebkit-1_0-2, dependendo da versão.

Se esses requisitos não são atendidos, o COMSOL falha ao acessar o sistema de ajuda.

Requisitos de Sistema Gráfico

A COMSOL recomenda renderização via hardware por razões de performance. A renderização via hardware requer drivers que suportem a versão 2.0 da OpenGL®. Usuários do Windows® também podem usar a versão 9 do DirectX®. A renderização via hardware requer, pelo menos, suporte a gráficos com cores 24-bit.

Alternativamente, pode-se usar a renderização via software. A configuração Optimize for Quality, nas preferências gráficas, requer OpenGL® 2.0. A renderização via software também suporta gráficos com cores 16-bit. Por razões de performance, nós recomendamos uma placa de vídeo com pelo menos 512MB de memória.

AMD®

Modelo de Placa Sistema Operacional Versão do Driver
AMD FirePro™ V4800 Ubuntu® 14.04 LTS 15.201.2401
AMD FirePro™ V5900 Ubuntu® 12.04 LTS 15.201.2401
AMD FirePro™ V7750 Windows Server® 2008 8.911.3.4000
AMD FirePro™ W2100 Red Hat Enterprise Linux® 7 15.302.2001
AMD FirePro™ W4100 Windows® 10 Enterprise 15.302.2001
AMD FirePro™ W4170M Windows® 7 14.301.1019
AMD FirePro™ W5000 Windows® 10 15.302.2001
AMD FirePro™ W5100 Windows® 8.1 15.302.2001
AMD FirePro™ W7000 Windows Server® 2012 R2 15.302.2001
AMD FirePro™ W7100 Windows® 7 15.201.2401
AMD FirePro™ W8000 Ubuntu® 16.04 LTS AMDGPU
AMD Radeon™ Pro WX4100 Windows® 10 16.50.2001

NVIDIA®

Modelo de Placa Sistema Operacional Versão do Driver
Quadro® K5000 Windows® 7 362.56
Quadro® K4000 Windows® 7 362.56
Quadro® K2200 Windows® 7 362.56
Quadro® K2000 Windows® 7 362.56
Quadro® M2000 Windows® 10 369.09
Quadro® K1200 Windows® 7 362.56
Quadro® K620 Windows® 10 362.56
Quadro® K620 Debian® 8 361.42
Quadro® 600 Debian® 8 361.45.11
Quadro® 600 Windows Vista® 348.40
Quadro® 410 Windows® 7 362.13
Quadro® FX 1800 Debian® 7 340.93
NVS 510 Ubuntu® 14.04 LTS 361.45.11
NVS 310 Ubuntu® 14.04 LTS 352.79
GeForce® GTX 950M Windows® 10 368.22

As placas gráficas listadas acima foram rigorosamente testadas para compatibilidade com o COMSOL Multiphysics®. Note, contudo, que outras placas gráficas AMD® ou NVIDIA® podem também ser compatíveis com o COMSOL Multiphysics®. As placas gráficas que pertencem às mesmas séries dos modelo listados acima têm maior probabilidade de serem compatíveis com o COMSOL Multiphysics®.

* Para aceleração via hardware no Linux®, use drivers proprietários do seu fabricante da placa de vídeo, tais como NVIDIA® ou AMD®. Caso contrário, use a renderização via software do COMSOL®. O driver de vídeo Nouveau somente é suportado para rederização via software.

Compiladores Oficialmente Suportados

Windows® macOS Linux®
C Externo Visual Studio® 2010 O Intel® Composer XE 2013.3 (também conhecido como Intel® Compiler versão 13.0.2) com GCC 4.2.1 é oficialmente suportado. O Intel® Composer XE 2013.4 (também conhecido como Intel® Compiler versão 13.1.2) com GCC 4.2.1 é oficialmente suportado
Java® API JDK 1.6, 1.7 ou 1.8 JDK 1.6, 1.7 ou 1.8 JDK 1.6, 1.7 ou 1.8
O COMSOL Multiphysics® é compilado e testado com os compiladores C/C++ acima. Note que versões mais recentes desses compiladores C/C++ podem também ser compatíveis com interfaces C externas. Quando usar a API para uso com Java® do COMSOL no modo cliente/servidor, com os arquivos jar listados em <installation dir>/bin/comsolclientpath.txt, são suportados JRE 1.6, JRE 1.7 e JRE 1.8. Quando usar a API para uso com Java® do COMSOL em modo standalone, com os arquivos listados em <installation dir>/bin/comsolpath.txt, apenas o JRE 1.8 é suportado.

Requisitos para Sistemas Paralelos *

Windows® Mac OS X Linux®
Paralelismo de Memória Compartilhada Todas versões suportadas do Windows® Todas versões suportadas de Mac OS X Todas distribuições Linux® suportadas
Paralelismo de Memória Distribuída
  • Windows Server® 2012 R2
  • Windows Server® 2012
  • Windows HPC Server 2008 R2
  • Windows HPC Server 2008
Não suportado
  • Red Hat® Enterprise Linux® 5, 6, e 7
  • Debian® 7 e 8
  • Ubuntu® 12.04 e 14.041

Todos os computadores do cluster devem usar a mesma versão do Linux® e devem possuir hardware similar. É recomendado que o OpenFabrics Enterprise Distribution (OFED) 1.5.4.1, ou posterior, esteja instalado. Se você estiver usando uma topologia de rede que suporte RDMA, um driver ou biblioteca compatível com DAPL 1.2, ou posterior, é necessário. O software normalmente é fornecido com o seu hardware.

1 Para paralelismo distribuído, usando memória compartilhada no Ubuntu® 14.04 LTS e 16.04 LTS, configure a variável de ambiente I_MPI_SHM_LMT para shm.

* A COMSOL se orgulha em ser membro do programa Intel® Cluster Ready e certifica o COMSOL Multiphysics® a cada nova versão. Ver Certificado. O processo de certificação assegura que o COMSOL Multiphysics® funcionará perfeitamente para processamento paralelo e modelagem em cluster em qualquer hardware que também tenha sido certificado como sendo Intel® Cluster Ready.

Intel Cluster Ready
Intel, Intel Cluster Ready e o texto Intel Cluster Ready são marcas registradas da Intel Corporation.

Gerenciador de Licenças Flexnet®

Os requisitos de sistema para o gerenciador de licenças são os mesmos que os do COMSOL Multiphysics®. A versão 11.13.1.4 do Flexnet® é usada no Windows® e a versão 11.13.1.3, no Linux® e Mac OS X. A versão do lmgrd deve ser a mesma ou mais recente do que a versão do Flexnet® usada pelo COMSOL.

Gerenciador de Licenças Flexnet® no Linux®

A Linux Standard Base (LSB™) é necessária agora para computadores servidores de licença que usam Linux®.

Se o pacote LSB™ estiver faltando no repositório da distribuição, crie manualmente um vínculo simbólico como root:

/lib64/ld-lsb-x86-64.so.3 -> ld-linux-x86-64.so.2

Distribuição Pacotes Requeridos
Debian® lsb-core
Ubuntu® lsb-core
Red Hat® redhat-lsb
SUSE lsb

NOTA: Esta informação é disponibilizada para o seu benefício e não deve substituir sua própria investigação sobre os requisitos de sistema que podem ser apropriados para seu uso do software COMSOL® ou outro software, dadas suas circunstâncias particulares. Sistemas e hardware mudam regularmente, o que pode impactar em qualquer determinação de quais requisitos de sistema são apropriados para você.